Moi anonyymi! » Login | Social login | Uusi käyttäjä

Linux-päivitys

harmaa kirjoitti noin 11 vuotta sitten (8 kommenttia)
Yleensä inhoan tietokoneen ylläpitoa, mutta tänä viikonloppuna oli sitten edessä Fedora Core 6 -päivitys. Edellinen FC4 taisi olla käytössä jo puolitoista vuotta. Laitoin kokonaan uuden asennuksen. Perussysteemin
pystyttäminen sujuu OK:ta klikkaamalla, mutta ennen kuin tästä saa kunnollisen täytyy tehdä vielä töitä.

Esimerkiksi LaTeX ja BibTex eivät asentuneet oletusarvoilla, ja Java on joku muu kuin tarvitsemani Sunin versio. Flash, Acrobat Reader, XMMS:n mp3-tuki ja mplayer avi-tiedostojen toistamiseen puuttuvat kaikki oletuspaketista.

Oletustyöpöydäksi tuli Gnome vaikka itse pidän enemmän KDE:stä. Vaihto onnistuu switchdesk-ohjelmalla, joka sekin pitää asentaa erikseen.

DVD-asennuksen jälkeen löytyy netistä yli 600 megaa päivityksiä, joiden lataaminen oli aika hidasta. Windows-maailmasta tähän on kopioitu tuollainen pup-niminen automaattinen päivitysprosessi, joka toimii taustalla. Itse hankkiuduin siitä nopeasti eroon ja otin yum:n käyttöön.

Yhteensopivuussyistä joudun käyttämään Latin1-skandeja oletusarvoisen UTF-8:n sijaan. Tämä vaatii /etc/sysconfig/i18n tiedoston editoimista. Löysin ohjeet yhdeltä foorumilta.

+/- saldo : 0 |

    harmaa kirjoitti noin 11 vuotta sitten+/- saldo : 0
    Näillä ohjeilla http://www.gagme.com/greg/linux/fc6-tips.php
    onnistuu ainakin osa jutuista melkein copy & pastella.

    Lerxst kirjoitti noin 11 vuotta sitten+/- saldo : 0
    Ja tota noin sitten sama vielä suomeksi! :D

    harmaa kirjoitti noin 11 vuotta sitten+/- saldo : 0
    Sama suomeksi:
    Tietokoneen Linux-käyttöjärjestelmä päivitettiin uudempaan versioon.

    Samaan aikaan ulkona alkoi vesisade.


    harmaa kirjoitti noin 11 vuotta sitten+/- saldo : 0
    Tämä lähinnä itselle muistiinpanoksi.

    Fedora Coren saa käyttämään Latin1-merkistöä UTF:n sijaan muokkaamalla /etc/sysconfig/i18n seuraavanlaiseksi:

    LANG="fi_FI"
    SUPPORTED="en_US:en:fi_FI@euro:en_US.UTF-8:en_US:en:fi_FI.UTF-8:fi_FI: fi"
    SYSFONT="latarcyrheb-sun16"

    FC4->FC6 -päivityksen seurauksena mplayerin AVI-outputti oli virheellistä. Ratkaisu oli vaihtaa mplayerin videoajuri lisäämällä tiedostoon ~/.mplayer/config seuraava rivi:

    vo=x11

    Graafisen tilan mplayerissa eli gmplayerissa on preferences-valikko asetuksen tekemistä varten.

    Muut tehdyt muutokset löytää osoitteesta http://www.gagme.com/greg/linux/fc6-tips.php
    . Ainoa virhe minkä siellä huomasin oli, että rivillä

    yum -y install xmms xmms-mp3 xmms-faad2 gstreamer-plugins-ugly libmad libid3tag

    tuo xmms-faad2 ei onnistu, vaan ensin päivityskomento annetaan ilman sitä, ja noiden muiden asennuttua erikseen yum -y xmms-faad2.



    retrou kirjoitti noin 11 vuotta sitten+/- saldo : 0
    Ei ihan heti tee mieli vaihtaa linuxiin. :)

    harmaa kirjoitti noin 11 vuotta sitten+/- saldo : 0
    No joo, on noita helpompia Linuxeja kuin Fedora Core. Esimerkiksi Ubuntua on kehuttu helpoksi. Kyllä itsekin täytyy myöntää että tämä FC6-päivitys oli pettymys. Pitänee sitten ensi joululomalla kokeilla jotakin toista distribuutiota.

    harmaa kirjoitti noin 11 vuotta sitten+/- saldo : 0
    Ja homma sen kuin paranee. Pdf-tiedostojen katseluun xpdf ei ole aina paras mahdollinen, esim. kanditutkielmassani ei näytä ilman zoomia kaikkia välimerkkejä oikein. Halusin siis Acrobat Readerin. Sen saikin kivasti ladattua rpm-paketissa Adoben sivuilta. Mutta käynnistyessä tulee vain virheilmoitus:

    expr: syntaksivirhe
    expr: syntaksivirhe
    expr: syntaksivirhe
    expr: syntaksivirhe
    (jatkuen loputtomiin)

    Ensimmäinen netistä löytämäni korjaus ongelmaan oli asentaa jokin "yhteensopivuuskirjasto" komennolla "yum install compat-libstdc++-33" mutta tämä ei tehnyt mitään. Sitten löysinkin saksankielisen (!) ohjeen osoitteesta http://www.fedorablog.de/archives/147-Fedora-Fix-fuer-Adobe-Reader.html

    jossa neuvotaan editoimaan /usr/bin/acroread-tiedoston rivi 418
    echo $mfile| sed 's/libgtk-x11-([0-9]*).0.so.0.([0-9])00.([0-9]*)|(.*)/123/g'
    muotoon
    echo $mfile| sed 's/libgtk-x11-([0-9]*).0.so.0.([0-9])000.([0-9]*)|(.*)/123/g'
    (eli tupla-0 vaihdetaan kolmeen 0:aan).

    Tämä tosiaan ratkaisi ongelman eli nyt toimii myös Acroread. Olkoonkin, että tuo on ilmeisesti Adobe Acrobat Readerin eikä Fedora Coren bugi, niin se kaiketi vain ilmenee sitten Fedorassa.


    harmaa kirjoitti noin 11 vuotta sitten+/- saldo : 0
    Muita havaittuja ongelmia:

    - Firefox lakkaa välillä reagoimasta linkkien klikkauksiin, Firefoxin päivitys uusimpaan 2.0.0.1-versioon ei korjannut ongelmaa joten vika saattaa olla muuallakin.

    - FC6:n Gnomessa oli sammuta-vaihtoehdon lisäksi "valmiustila": se kyllä nukutti koneeni mutta käynnistettäessä uudelleen kone jumiutui ja tuli todella dramaattisia virheilmoituksia mm. I/O-virheistä joka konsoliin

    Yhteenvetona olen kyllä varsin pettynyt tähän uuteen Fedora Coreen. Jos tietäisin varmuudella jonkin paremman vaihtoehdon, jossa testatusti toimivat nuo vaatimani LaTeX, BibTex ja Beamer, niin voisin jopa harkita siihen siirtymistä. FC:tä olen käyttänyt 3 vuotta ja sitä ennen Red Hatin eri versioita.